Trucs et astuces

De Documentation de la solution web de gestion OpenFlyers version 3
Aller à : navigation, rechercher

Présentation

L'objet de cette page est de présenter des trucs et astuces généraux et indépendants de l'utilisation d'OpenFlyers .

Administration réseau

Trouver l'adresse IP du routeur

Pour connaître l'adresse IP d'une passerelle (box ou routeur).

Trouver l'adresse IP du routeur freebox à distance

  • Aller sur le site de free.
  • Cliquer sur Mon compte
  • Saisir l'identifiant et le mot de passe du compte pour lequel on souhaite connaitre l'adresse IP
  • Aller sur Ma Freebox > Afficher mon adresse IP
  • L'adresse IP est indiquée dans le champ Votre adresse IP :

Cette adresse IP dite "fixe" est présente avec le message Ceci est votre adresse IP, pour les abonnés dégroupés ainsi que les abonnés IPADSL ayant demandé une IP Fixe

Trouver l'adresse IP du routeur sous Windows

  • Ouvrir une console
  • Taper ipconfig /all pour afficher la structure de la connexion au réseau.
  • L'adresse du routeur est indiquée à la ligne passerelle par défaut de la carte Ethernet du PC pour une connexion par câble RJ45 ou sous la carte WLAN pour une connexion sans fil (par exemple wifi).

Trouver l'adresse IP du routeur par l'interface graphique de Windows 7

  • Cliquer sur le bouton Démarrer
  • cliquer sur Panneau de configuration
  • Cliquer sur Réseau et Internet
  • Cliquer sur Centre de réseau et partage
  • Cliquer sur Afficher l'intégralité du réseau dan
  • Survoler l’icône Passerelle : l'adresse IP du matériel apparait dans le popup

Reseau_W7.jpg

Sous Linux

  • Ouvrir une console
  • Taper « netstat -r -n »
  • L'adresse IP est dans la colonne Passerelle (Gateway en Anglais)

Reseau_Linux.jpg

Monitoring d'une freebox

Connexion à un routeur

Connexion à distance à une livebox

Prérequis :

  • la livebox doit avoir été configurée pour permettre une contrôle à distance
  • Il faut connaitre l'adresse IP externe de la livebox, soit parce qu'elle est fixe, soit parce qu'un service Dynamic DNS a été mis en place
  • Dans un navigateur saisir l'URL pour accéder à la livebox. Cette URL doit être écrite avec "https://" suivie de l'adresse IP externe de la livebox suivie de ":10000" qui correspond au port par défaut proposée par la livebox lors de la mise en place d'une connexion à distance. Cela donne une URL sous la forme : https://X.X.X.X:10000
  • Dans le champ identifiant, saisir l'identifiant créé pour la connexion à distance
  • Dans le champ mot de passe, saisir le mot de passe créé pour la connexion à distance
  • Cliquer sur le bouton s'identifier

Editer un fichier texte

Nous recommandons l'utilisation de l'outil Notepad++ pour visualiser ou modifier un fichier texte depuis un ordinateur sous système d'exploitation Windows.

Effectuer une copie d'écran

Nous recommandons l'utilisation de l'outil Greenshot pour effectuer une copie d'écran depuis un ordinateur sous système d'exploitation Windows.

Une fois le logiciel installé et lancé, il suffit d'appuyer sur la touche "Imp. écr" du clavier pour lancer la copie d'écran. Greenshot vous permettra alors de sélectionner la zone à copier puis vous proposera de sauvegarder le fichier.

Lorsque la copie d'écran doit être envoyée par e-mail ou ajouter dans un rapport de bug, il est indispensable de la communiquer sous son format d'origine c'est à dire au format png ou jpg. Surtout, ne mettez pas vos copies d'écran dans un document texte : cela rend son exploitation difficile.

LibreOffice

Les procédures suivantes sont normalement identiques sous OpenOffice et existent également sous Word ou Excel mais avec des commandes différentes.

Afficher uniquement un certain type de lignes

Cas pratique : lors de l'import des à nouveaux, lorsqu'il existe plusieurs types de comptes par utilisateur, il peut être intéressant de n'afficher que les lignes d'un seul type de compte à la fois

Dans LibreOffice, une fois que le document à traiter est ouvert :

  • "Données > Filtre > AutoFiltre"

Cela fait apparaitre à droite de chaque cellule de la première colonne une flèche

  • Cliquer sur la flèche correspondante à la cellule dont on souhaite restreindre les types de données visibles (exemple : cellule "account_type_name" pour ne faire apparaitre qu'un seul type de compte)
  • Sélectionner/désélectionner les types de données à faire apparaitre/disparaitre

Changer le format d'affichage des dates dans une colonne

  • Positionner le pointeur de la souris sur la lettre de la colonne concernée
  • Effectuer un clic droit pour faire apparaitre le menu contextuel
  • Sélectionner Formater les cellules... pour faire apparaitre une boite de dialogue intitulée Formatage des cellules
  • Laisser sélectionné le premier onglet Nombres
  • Dans le champ Catégorie, sélectionner "Date"
  • Dans le champ Format, sélectionner le format souhaité si existant (penser à utiliser l'ascenseur du champ pour faire défiler l'intégralité des formats proposés)
  • Si le format souhaité est inexistant, dans le champ Description de format, renseigner le format souhaité

Pour construire le format souhaité, il suffit en général de s'inspirer des formats existants. Exemple de format pour les dates tel que demandé pour l'import des utilisateurs dans OpenFlyers : "YYYY-MM-DD"

  • Cliquer sur le bouton OK

Exporter au format csv pour OpenFlyers

Dans OpenFlyers, l'encodage de caractère par défaut utilisé est l'UTF-8 et la séparation entre les champs est le point-virgule. Voici comment effectuer un export de fichier .csv respectant ces éléments :

  • Sélectionner Fichier > Enregistrer sous...
  • Choisir le répertoire et le nom de fichier
  • Dans le champ Type sélectionner Texte CSV (.csv) (*.csv)
  • Cocher Éditer les paramètres du filtre
  • Cliquer sur le bouton Enregistrer

Dans la fenêtre Export de fichiers texte :

  • Dans le champ Jeu de caractères taper la lettre "U" puis sélectionner Unicode (UTF-8)
  • Appuyer sur la touche TAB pour éditer le champ suivant, cela permet non seulement de mettre le focus dans le champ mais également de sélectionner tout le contenu de la cellule
  • Dans le champ Séparateur de champ, taper ";"
  • Appuyer sur la touche TAB
  • Taper sur la touche "Supprimer" du clavier de sorte à vider le contenu du champ Séparateur de texte
  • Cliquer sur le bouton OK

Modifier le comportement la souris

Voici les procédures pour modifier le comportement de la souris, et notamment le "clic molette" dont nous recommandons l'usage dans la version 3 d'OpenFlyers :

Navigateurs

Empêcher la mémorisation des saisies dans les formulaires

Sur Chrome :

  • Icône menu > Paramètres
  • Afficher les paramètres avancés
  • Chapitre Mots de passe et formulaires : décocher Activer la saisie automatique pour remplir les formulaires Web en un simple clic

Sur Firefox :

  • Outils > Options
  • Vie privée
  • Chapitre Historique, décocher Conserver l’historique des recherches et des formulaires

Imprimer avec un navigateur

Imprimer avec Chrome

  • Cliquer sur le bouton en haut à droite de la barre de navigation symbolisant un menu (trois traits horizontaux)
  • Imprimer...

Imprimer avec Firefox

  • Fichier > Imprimer...

Alternative si le menu n'est pas disponible :

  • Cliquer sur le bouton en haut à droite de la barre de navigation symbolisant un menu (trois traits horizontaux)
  • Cliquer sur le bouton symbolisant une imprimante

Supprimer une saisie automatique

Si le navigateur est paramétré pour enregistrer les champs dans un formulaire, il peut être nécessaire de pouvoir supprimer une entrée. C'est par exemple le cas lorsque l'on saisit par erreur son mot de passe dans le champ identifiant et qu'il se retrouve ainsi mémorisé en clair.

Dans le cas d'un ordinateur en accès public, il est déconseillé de paramétrer les navigateurs pour permettre cet enregistrement automatique. Voir Empêcher la mémorisation des saisies dans les formulaires.

Pour supprimer cette entrée il faut :

  • Saisir le début du texte jusqu'à ce que l'entrée à supprimer apparaisse dans la liste des propositions en auto-complétion.
  • Positionner le curseur de la souris sur l'entrée à supprimer.
  • Appuyer sur la touche Suppr du clavier.

Ouvrir une console sous Windows

Ouvrir une console sous Windows 7

  • Cliquer sur le bouton Démarrer
  • Dans le champs Rechercher taper cmd puis sélectionner le fichier cmd.exe.
  • Taper sur la touche "Entrer" pour ouvrir la console DOS.

Ouvrir une console sous Windows 8

  • Aller avec le pointeur de la souris dans le coin inférieur gauche de l'écran
  • Le petit rectangle Accueil doit s'afficher : cliquer sur le bouton droit de la souris
  • Un menu contextuel doit s'afficher : cliquer sur l'item Exécuter
  • Une fenêtre Exécuter doit s'ouvrir. Taper cmd dans le champ Ouvrir et valider avec la touche "Entrer" pour ouvrir la console DOS.