Compatibilité des navigateurs

De Documentation de la solution web de gestion OpenFlyers version 3
Aller à : navigation, rechercher

Présentation

Cette page présente la compatibilité des versions d'OpenFlyers pour chaque navigateur.

D'une façon générale nous déconseillons l'usage du navigateur Internet Explorer qui souffre depuis toujours d'un retard dans la mise en place des technologies du web et le respect des standards. A la place, nous recommandons sur Windows, l'usage de Google Chrome ou de Mozilla Firefox.

Navigateur compatible avec l'armoire à clés

Pour un fonctionnement avec une armoire à clé, le club doit être en HTTPS mais le dialogue entre le navigateur et le daemon est en HTTP. Le mixage des contenus HTTPS et HTTP est considéré comme anormal par les navigateurs car il y a une possibilité d'intrusion « Man in the middle ». Ce risque n'existe pas sur le réseau local. Il faut neutraliser ce bouclier dans les navigateurs :

  • IE toute version: ne fonctionne pas avec l'armoire
  • Firefox il faut mettre le paramètre security.mixed_content.block_active_content à false
    • Ouvrir Firefox
    • Saisir dans la barre d’adresse : about:config
    • Rechercher : security.mixed_content.block_active_content
    • Double-cliquer pour changer la valeur de true en : false
  • Chrome il faut ajouter le paramètre --allow-running-insecure-content
    • Clic droit sur l’icône Google Chrome sur le bureau.
    • Sélectionner Propriétés
    • A la fin des informations du champ Cible ajouter " --allow-running-insecure-content" (il y a un espace avant le premier tiret).
    • Cliquer sur OK.

Versions supportées

Le tableau ci-dessous présente les versions des navigateurs les plus utilisés à partir desquelles le logiciel OpenFlyers peut être utilisé.

OpenFlyers Internet Explorer Google Chrome Mozilla Firefox Opera Safari
version 1.3 version >= 8 version >= 4 version >= 3.5 version >= 10.5 version >= 5
version 2.1 versions 8 et 9 version >= 4 version >= 3.5 version >= 10.5 version >= 5
version 3.5 version >= 8 version >= 4 version >= 3.5 version >= 10.5 version >= 5
version 4 non supporté version >= 4 version >= 3.5 version >= 10.5 version >= 5